Topic Options
#6413 - 06/27/10 12:21 AM Lexicon PSP42 & PSP 84 updated to version 1.6.0
admin Offline

Member

Registered: 10/15/01
Posts: 240
Dear user,

We are pleased to inform that new versions of the Lexicon PSP42 (v. 1.6.0) and PSP 84 (v. 1.6.0) have been released.
The update is free for registered users. Please log-in to your account at PSP Registration Center to find download links to newest versions and your new authorization details.
Due to technical limitations newest version of the PSP 42 and 84 are available in the non ilok version only.

Have a great Summer!
PSP team
http://www.PSPaudioware.com


New features:
1. AudioUnit supports MAC 64bit (x86_64) natively.
2. GUI is Cocoa-based (no more Carbon). Audio application capable of hosting AudioUnits with Cocoa view is needed to run AU. Minimum system requirement for AU is OSX 10.5.
3. Plug-in has been built with new version of graphic library and benefits from event-driven architecture.
4. New version of presetbar is used. It allows for setting default bank and preset by double-clicking on 'bank' or 'preset' at the bottom bar.
5. Plug-in uses chunks to save its state in session file. Entire bank is restored on load.


Minimum system requirements

MAC:

AudioUnit:
- Mac OSX 10.5 or later
- 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view

VST
- Mac OSX 10.4 or later
- VST 2.4 compatible application

RTAS
- Mac OSX 10.4 or later
- ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)


PC:

VST:
- Windows XP Service Pack 2, Windows Vista or Windows 7 operating system
- VST 2.4 compatible application

RTAS
- Windows XP Service Pack 2, Windows Vista or Windows 7 operating system
- ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

Top
#6416 - 06/29/10 03:27 AM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: admin]
Dandruff Offline
Member

Registered: 11/26/05
Posts: 18
\:\(


Crash in REAPER http://www.pspaudioware.net/forum/ubbthreads.php?ubb=showflat&Number=6314#Post6314 not fixed!



Even more bad:
1.6.0 says that my authorization data is incorrect \:\(




Guys, that's unacceptable. 1.5.3 at least took my authorization data. Is it because of a "ß" in my name?


Please have a look at it and contact me as soon as possible!




More bugs in 1.6.0:


1. My authorization data isn't working anymore. In 1.5.3 it's working properly! Why?

2. CTRL+V (pasting authorization data into input fields) doesn't work in REAPER. I have to use rightclick menu to paste.

3. Spacebar isn't treated correctly in any input fields. It starts/stops playback in REAPER. I have to use SHIFT+Spacebar to get a blank in input fields. Should be fixed. Doesn't happen with other plugins (Voxengo for example)!




How long will it take to get a proper working version?


I'm also quite disappointed that you didn't send me the 1.6.0 version before releasing it as you promised me.

Top
#6418 - 06/29/10 09:36 AM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: Dandruff]
Dandruff Offline
Member

Registered: 11/26/05
Posts: 18
 Originally Posted By: Dandruff
Even more bad:
1.6.0 says that my authorization data is incorrect


Ok, there's a new key in my User Area. But this key also doesn't work!?

Top
#6419 - 06/29/10 03:48 PM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: Dandruff]
Dandruff Offline
Member

Registered: 11/26/05
Posts: 18
Ok, Antoni changed my name/key to new one and this is working now.

Top
#6422 - 06/30/10 05:06 PM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: Dandruff]
studilaroche Offline
New Member

Registered: 06/30/10
Posts: 1
I recently updated the PCM42 delay to the latest version- 1.6.0.
I am finding when I put the delay into CLK mode once I stop playback it reverts
back to '1 1' setting disregarding any other setting I have chosen.
I am running ProTools HD v 8.0.1 on a Mac Pro 2.66 Quad with OS 10.5.8.
Thanks so much for your attention to this! For the time being I'll simply revert back to the previous version of the plug-in.

Top
#11260 - 12/25/15 01:16 PM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: admin]
Magnus Offline
New Member

Registered: 12/25/15
Posts: 2
Hi,

I have been using my PSP plugins on a Win XP system. Now I am transferring them to Win 7 - and in a few weeks, finally, to a Win 10 system. However, like for Dandruff above, the license file for my Lexicon PSP42 doesn't work. My last name is Nordén, and I believe the é may cause problems.

Also, the license key (series of numbers) for authorising my PSP84 doesn't work either.

I would appreciate a solution so that I can authorise my plugins.

Merry Christmas for now!

Magnus

Top
#11282 - 12/29/15 09:51 AM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: admin]
admin Offline

Member

Registered: 10/15/01
Posts: 240
Problem has been already solved.


Edited by admin (12/29/15 09:51 AM)

Top
#11286 - 12/29/15 05:07 PM Re: Lexicon PSP42 & PSP 84 updated to version 1.6.0 [Re: admin]
Magnus Offline
New Member

Registered: 12/25/15
Posts: 2
Originally Posted By: admin
Problem has been already solved.


True.

/Magnus


Edited by Magnus (12/29/15 05:08 PM)

Top